Cannot Trade BAM on Uniswap

I have been trying to trade BAM on Uniswap with no success. When I click to confirm I get the spinning “Waiting” screen then it simply resets back to the original confirm page. This loop continues indefinitely and I cant get past it. I have tried all of the following ‘tricks’ to try to get it to work without success:

Increasing slippage to 5% and 10%, and everything in between.
Adding ‘.00’ or ‘9’ to the end of each token in the swap.
Reducing the amount of each token/using even numbers.
Changing the coin to be swapped for BAM. Tried ETH and several other ERC20 tokens.
Changing the coin to be swapped for BAM to something other than an ERC20 token.
Changing browsers.
Trying the swap on a desktop computer rather than a phone.
Tried moving BAM to a different wallet, when entering the new contract address I receive an error that it’s a personal address and please enter a valid contract address.

I’ve spent hours trying to swap BAM, but still no luck. I have verified that I’m using the correct contract address for the new BAM ERC20 token and that the new BAM token is in fact in my wallet. Is anyone else having this issue? Any help with fixing this is appreciated.

Have a look at this thread:

Does that seem like the issue you’ve been encountering?

(Btw the DAO vote regarding this issue is still going for another 20 min or so, if you want to participate in that as well)

1 Like

I suppose that could be the cause of this glitch. I will wait until this is resolved and then try again. Thank you for the quick response.

1 Like

The buy and sell fees were removed today (immutable - never to be taxed again!)…try again?


Worked like a charm. Thank you.

What is it valued at on uniswap?